Как настроить новый скрипт для плеера?

Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#1
Уже почти месяц прошёл, а я всё никак не разберусь...

Установил сайт с нуля.
Наполнил базу фильмами.
Зашёл в модуль плеер и выключил "Показывать только первый успешный результат".
Api прописал вот такие

Код:
/api?token=TEST&id=[id] ~ "" ~ result.embed <> _VALUE_?season=[season]&episode=[episode]

/api?token=TEST&id=[id] ~ "Трейлер" ~ result.trailer

https://api.themoviedb.org/3/[type]/[tmdb_id]?language=ru&append_to_response=videos&api_key=269890f657dddf4635473cf4cf456576 ~ "Трейлер (TMDb)" ~ videos.results.0.key <> https://www.youtube.com/embed/_VALUE_ ~ videos.results.0.key <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://www.googleapis.com/youtube/v3/search?part=id,snippet&maxResults=1&key=AIzaSyCsT5C4pBFWpzyP4hEOen2ZBhn26AhMCkM&q=[title] [year] трейлер ~ "Трейлер (YouTube)" ~ items.0.id.videoId <> https://www.youtube.com/embed/_VALUE_ ~ items.0.id.videoId <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://api.bhcesh.me/list?token=eedefb541aeba871dcfc756e6b31c02e&kinopoisk_id=[kp_id] ~ results.0.iframe_url

https://videocdn.tv/api/short?api_token=pfp3D870PGEY3Afjti0gMtSfmn2aZqih&kinopoisk_id=[kp_id] ~ data.0.iframe_src

https://pleer.video/[kp_id].json ~ embeds.0.iframe

https://api.alloha.tv/?token=d317441359e505c343c2063edc97e7&kp=[kp_id] ~ data.iframe

https://bazon.cc/api/search?token=2848f79ca09d4bbbf419bcdb464b4d11&kp=[kp_id] ~ results.0.link

https://kodikapi.com/search?token=b7cc4293ed475c4ad1fd599d114f4435&kinopoisk_id=[kp_id] ~ results.0.link

https://apivb.info/api/videos.json?token=5e2fe4c70bafd9a7414c4f170ee1b192&id_kp=[kp_id] ~ iframe_url

https://iframe.video/api/v2/search?kp=[kp_id] ~ results.path

Лупа бегает но плееров нет.
Модуль "блокировка просмотра" отключен.

Что ещё нужно сделать?
 
Енот
Новичо́к, через «о́»
Регистрация
9 Май 2020
Сообщения
701
#2
Уже почти месяц прошёл, а я всё никак не разберусь...

Установил сайт с нуля.
Наполнил базу фильмами.
Зашёл в модуль плеер и выключил "Показывать только первый успешный результат".
Api прописал вот такие

Код:
/api?token=TEST&id=[id] ~ "" ~ result.embed <> _VALUE_?season=[season]&episode=[episode]

/api?token=TEST&id=[id] ~ "Трейлер" ~ result.trailer

https://api.themoviedb.org/3/[type]/[tmdb_id]?language=ru&append_to_response=videos&api_key=269890f657dddf4635473cf4cf456576 ~ "Трейлер (TMDb)" ~ videos.results.0.key <> https://www.youtube.com/embed/_VALUE_ ~ videos.results.0.key <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://www.googleapis.com/youtube/v3/search?part=id,snippet&maxResults=1&key=AIzaSyCsT5C4pBFWpzyP4hEOen2ZBhn26AhMCkM&q=[title] [year] трейлер ~ "Трейлер (YouTube)" ~ items.0.id.videoId <> https://www.youtube.com/embed/_VALUE_ ~ items.0.id.videoId <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://api.bhcesh.me/list?token=eedefb541aeba871dcfc756e6b31c02e&kinopoisk_id=[kp_id] ~ results.0.iframe_url

https://videocdn.tv/api/short?api_token=pfp3D870PGEY3Afjti0gMtSfmn2aZqih&kinopoisk_id=[kp_id] ~ data.0.iframe_src

https://pleer.video/[kp_id].json ~ embeds.0.iframe

https://api.alloha.tv/?token=d317441359e505c343c2063edc97e7&kp=[kp_id] ~ data.iframe

https://bazon.cc/api/search?token=2848f79ca09d4bbbf419bcdb464b4d11&kp=[kp_id] ~ results.0.link

https://kodikapi.com/search?token=b7cc4293ed475c4ad1fd599d114f4435&kinopoisk_id=[kp_id] ~ results.0.link

https://apivb.info/api/videos.json?token=5e2fe4c70bafd9a7414c4f170ee1b192&id_kp=[kp_id] ~ iframe_url

https://iframe.video/api/v2/search?kp=[kp_id] ~ results.path

Лупа бегает но плееров нет.
Модуль "блокировка просмотра" отключен.

Что ещё нужно сделать?
Отключи показывать только первый успешный результат
 
Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#3
Енот
Новичо́к, через «о́»
Регистрация
13 Янв 2018
Сообщения
485
#5
Уже почти месяц прошёл, а я всё никак не разберусь...

Установил сайт с нуля.
Наполнил базу фильмами.
Зашёл в модуль плеер и выключил "Показывать только первый успешный результат".
Api прописал вот такие

Код:
/api?token=TEST&id=[id] ~ "" ~ result.embed <> _VALUE_?season=[season]&episode=[episode]

/api?token=TEST&id=[id] ~ "Трейлер" ~ result.trailer

https://api.themoviedb.org/3/[type]/[tmdb_id]?language=ru&append_to_response=videos&api_key=269890f657dddf4635473cf4cf456576 ~ "Трейлер (TMDb)" ~ videos.results.0.key <> https://www.youtube.com/embed/_VALUE_ ~ videos.results.0.key <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://www.googleapis.com/youtube/v3/search?part=id,snippet&maxResults=1&key=AIzaSyCsT5C4pBFWpzyP4hEOen2ZBhn26AhMCkM&q=[title] [year] трейлер ~ "Трейлер (YouTube)" ~ items.0.id.videoId <> https://www.youtube.com/embed/_VALUE_ ~ items.0.id.videoId <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://api.bhcesh.me/list?token=eedefb541aeba871dcfc756e6b31c02e&kinopoisk_id=[kp_id] ~ results.0.iframe_url

https://videocdn.tv/api/short?api_token=pfp3D870PGEY3Afjti0gMtSfmn2aZqih&kinopoisk_id=[kp_id] ~ data.0.iframe_src

https://pleer.video/[kp_id].json ~ embeds.0.iframe

https://api.alloha.tv/?token=d317441359e505c343c2063edc97e7&kp=[kp_id] ~ data.iframe

https://bazon.cc/api/search?token=2848f79ca09d4bbbf419bcdb464b4d11&kp=[kp_id] ~ results.0.link

https://kodikapi.com/search?token=b7cc4293ed475c4ad1fd599d114f4435&kinopoisk_id=[kp_id] ~ results.0.link

https://apivb.info/api/videos.json?token=5e2fe4c70bafd9a7414c4f170ee1b192&id_kp=[kp_id] ~ iframe_url

https://iframe.video/api/v2/search?kp=[kp_id] ~ results.path

Лупа бегает но плееров нет.
Модуль "блокировка просмотра" отключен.

Что ещё нужно сделать?
Даже трейлеры не отображаются?
 
Енот
Новичо́к, через «о́»
Регистрация
13 Июн 2020
Сообщения
136
#7
Уже почти месяц прошёл, а я всё никак не разберусь...

Установил сайт с нуля.
Наполнил базу фильмами.
Зашёл в модуль плеер и выключил "Показывать только первый успешный результат".
Api прописал вот такие

Код:
/api?token=TEST&id=[id] ~ "" ~ result.embed <> _VALUE_?season=[season]&episode=[episode]

/api?token=TEST&id=[id] ~ "Трейлер" ~ result.trailer

https://api.themoviedb.org/3/[type]/[tmdb_id]?language=ru&append_to_response=videos&api_key=269890f657dddf4635473cf4cf456576 ~ "Трейлер (TMDb)" ~ videos.results.0.key <> https://www.youtube.com/embed/_VALUE_ ~ videos.results.0.key <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://www.googleapis.com/youtube/v3/search?part=id,snippet&maxResults=1&key=AIzaSyCsT5C4pBFWpzyP4hEOen2ZBhn26AhMCkM&q=[title] [year] трейлер ~ "Трейлер (YouTube)" ~ items.0.id.videoId <> https://www.youtube.com/embed/_VALUE_ ~ items.0.id.videoId <> https://img.youtube.com/vi/_VALUE_/sddefault.jpg

https://api.bhcesh.me/list?token=eedefb541aeba871dcfc756e6b31c02e&kinopoisk_id=[kp_id] ~ results.0.iframe_url

https://videocdn.tv/api/short?api_token=pfp3D870PGEY3Afjti0gMtSfmn2aZqih&kinopoisk_id=[kp_id] ~ data.0.iframe_src

https://pleer.video/[kp_id].json ~ embeds.0.iframe

https://api.alloha.tv/?token=d317441359e505c343c2063edc97e7&kp=[kp_id] ~ data.iframe

https://bazon.cc/api/search?token=2848f79ca09d4bbbf419bcdb464b4d11&kp=[kp_id] ~ results.0.link

https://kodikapi.com/search?token=b7cc4293ed475c4ad1fd599d114f4435&kinopoisk_id=[kp_id] ~ results.0.link

https://apivb.info/api/videos.json?token=5e2fe4c70bafd9a7414c4f170ee1b192&id_kp=[kp_id] ~ iframe_url

https://iframe.video/api/v2/search?kp=[kp_id] ~ results.path

Лупа бегает но плееров нет.
Модуль "блокировка просмотра" отключен.

Что ещё нужно сделать?
Через консоль посмотрите какая ошибка
 
Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#9
видимо не правильно составлен api запрос в модуле плеер
 
Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#10
Вот пример запроса

https://kodikapi.com/search?token=мой_ключ_полученный_на_кодик&kinopoisk_id=[kp_id] ~ "Kodik" ~ results.0.link

На другом сайте (с старой версией cinemapress) запрос отлично работает
 
Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#11
Основной id фильмов на обоих сайтах kinopoisk
 
Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#12
На третьем сайте тоже ничего не отображается
 
Регистрация
15 Дек 2017
Сообщения
5,068
#17
  • На последней версии
  • Добавляется фильм
  • Прописаны API-строки из поста
  • Отключен показ только первого успешного
  • Плееры все находятся
 
Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#18
Енот
Новичо́к, через «о́»
Регистрация
3 Апр 2020
Сообщения
349
#19
Код:
[TAILING] Tailing last 50 lines for [all] processes (change the value with --lines option)
/home/dorama.by/log/err-0.log last 50 lines:
0|dorama.b | 2021-07-20T23:54:47: https://pleer.video/413405664.json null 404
0|dorama.b | 2021-07-20T23:55:43: https://pleer.video/407097796.json null 404
0|dorama.b | 2021-07-20T23:56:12: https://pleer.video/401634006.json null 404
0|dorama.b | 2021-07-21T08:39:59: https://pleer.video/413405664.json null 404
у этого сайта id не кинопоиска
восстановил бэкап из mega
может старая база фильмов не работает с этими плеерами? или ещё что...
 
Енот
Новичо́к, через «о́»
Регистрация
9 Май 2020
Сообщения
701
#20