Как навсегда избавиться от протокола https при блокировке страницы сайта?

Енот
Новичек
Регистрация
17 Янв 2018
Сообщения
100
#1
Всем привет. Суть вопроса. РКН заблочил страницу на сайте с протоколом https. Соответственно весь сайт недоступен. Эту проблему знают все, дело не в ней. Теперь внимание вопрос: как НАВСЕГДА избавиться от любого упоминания https в конфигах сайта и спокойно вернуться на http? Вопрос неспроста, ибо после закомментирования всех упоминаний о https в конфиге nginx в etc, сайт начинает худо-бедно работать на http с периодическими выбросами в 403 ошибку nginx. Но стоит только нам сделать hard restart и все настройки htpps чудесным образом возвращаются на место в файле конфига! И опять все по-новой! Как на http то мне теперь вернуться?
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
1,756
#2
Всем привет. Суть вопроса. РКН заблочил страницу на сайте с протоколом https. Соответственно весь сайт недоступен. Эту проблему знают все, дело не в ней. Теперь внимание вопрос: как НАВСЕГДА избавиться от любого упоминания https в конфигах сайта и спокойно вернуться на http? Вопрос неспроста, ибо после закомментирования всех упоминаний о https в конфиге nginx в etc, сайт начинает худо-бедно работать на http с периодическими выбросами в 403 ошибку nginx. Но стоит только нам сделать hard restart и все настройки htpps чудесным образом возвращаются на место в файле конфига! И опять все по-новой! Как на http то мне теперь вернуться?
Закомментировать в файлах:
  • /home/сайт/config/default/nginx/conf.d/nginx.conf
  • /home/сайт/config/production/nginx/conf.d/nginx.conf
  • /etc/nginx/conf.d/сайт.conf
Строки:
  • # Non WWW start
  • #nonWWW server {listen 443 ...
  • # Non WWW end
  • ----------------------------
  • # Only HTTPS start
  • #onlyHTTPS server {listen 80 ...
  • # Only HTTPS end
  • ----------------------------
  • # Enable HTTPS start
  • #enableHTTPS listen 443 ...
  • # Enable HTTPS end
Выполнить команду удаления:
  • rm -rf /etc/letsencrypt /etc/nginx/ssl
Выполнить команду перезагрузки:
  • wget cinemapress.org/i -qO i && chmod +x i && ./i hard_restart
 
Енот
Новичек
Регистрация
17 Янв 2018
Сообщения
100
#3
Закомментировать:
  • /home/сайт/config/default/nginx/conf.d/nginx.conf
  • /home/сайт/config/production/nginx/conf.d/nginx.conf
  • /etc/nginx/conf.d/сайт.conf
Строки:
  • # Non WWW start
  • #nonWWW server {listen 443 ...
  • # Non WWW end

  • # Only HTTPS start
  • #onlyHTTPS server {listen 80 ...
  • # Only HTTPS end

  • # Enable HTTPS start
  • #enableHTTPS listen 443 ...
  • # Enable HTTPS end
Перезагрузить:
  • wget cinemapress.org/i -qO i && chmod +x i && ./i hard_restart
Если бы было все так просто... В 3-х этих файлах весь ssl закомментирован. При этом после перезагрузки сайта в двух файлах в home так и остается закомментированным а вот в файле сайт.conf в etc волшебным образом возвращается на место....
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
1,756
#4
Удалите Ваши сертификаты с сервера:
  • rm -rf /etc/letsencrypt /etc/nginx/ssl
 
Енот
Новичек
Регистрация
17 Янв 2018
Сообщения
100
#5
Удалите Ваши сертификаты с сервера:
  • rm -rf /etc/letsencrypt /etc/nginx/ssl
Удалил сертификаты, закомментировал https, hard_restart и.. ошибка 500. В pm2 logs:
Код:
PM2        | 2018-11-21T20:51:15: PM2 log: ===============================================================================
PM2        | 2018-11-21T20:51:15: PM2 log: --- New PM2 Daemon started ----------------------------------------------------
PM2        | 2018-11-21T20:51:15: PM2 log: Time                 : Wed Nov 21 2018 20:51:15 GMT+0300 (Moscow Standard Time)
PM2        | 2018-11-21T20:51:15: PM2 log: PM2 version          : 3.2.2
PM2        | 2018-11-21T20:51:15: PM2 log: Node.js version      : 10.13.0
PM2        | 2018-11-21T20:51:15: PM2 log: Current arch         : x64
PM2        | 2018-11-21T20:51:15: PM2 log: PM2 home             : /root/.pm2
PM2        | 2018-11-21T20:51:15: PM2 log: PM2 PID file         : /root/.pm2/pm2.pid
PM2        | 2018-11-21T20:51:15: PM2 log: RPC socket file      : /root/.pm2/rpc.sock
PM2        | 2018-11-21T20:51:15: PM2 log: BUS socket file      : /root/.pm2/pub.sock
PM2        | 2018-11-21T20:51:15: PM2 log: Application log path : /root/.pm2/logs
PM2        | 2018-11-21T20:51:15: PM2 log: Process dump file    : /root/.pm2/dump.pm2
PM2        | 2018-11-21T20:51:15: PM2 log: Concurrent actions   : 2
PM2        | 2018-11-21T20:51:15: PM2 log: SIGTERM timeout      : 1600
PM2        | 2018-11-21T20:51:15: PM2 log: ===============================================================================
Никакого упоминания о процессе
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
1,756
#6
Сделайте hard_restart еще раз и затем посмотрите tail -f /var/log/nginx/*.log
 
Енот
Новичек
Регистрация
17 Янв 2018
Сообщения
100
#8
@Alisa, Отписываюсь - сайт частично заработал (только моб. версия с поддоменом m.) Обычная версия упорно редиректит на https. Во всех 3х файлах https сейчас закомментирован, сертификаты удалены, в настройках стоит протокол http. Хелп? :cry:
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
1,756
#9
@Alisa, Отписываюсь - сайт частично заработал (только моб. версия с поддоменом m.) Обычная версия упорно редиректит на https. Во всех 3х файлах https сейчас закомментирован, сертификаты удалены, в настройках стоит протокол http. Хелп? :cry:
Покажите service nginx restart
 
Енот
Новичек
Регистрация
17 Янв 2018
Сообщения
100
#10
Рестарт сейчас без ошибок, поэтому вот результат
Код:
systemctl status nginx.service
● nginx.service - nginx - high performance web server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-11-21 21:35:28 MSK; 55s ago
     Docs: http://nginx.org/en/docs/
  Process: 10355 ExecStop=/bin/kill -s TERM $MAINPID (code=exited, status=0/SUCCESS)
  Process: 10359 ExecStart=/usr/sbin/nginx -c /etc/nginx/nginx.conf (code=exited, status=0/SUCCESS)
Main PID: 10360 (nginx)
    Tasks: 17 (limit: 4915)
   CGroup: /system.slice/nginx.service
           ├─10360 nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf
           ├─10361 nginx: worker process
           ├─10362 nginx: worker process
           ├─10363 nginx: worker process
           ├─10364 nginx: worker process
           ├─10365 nginx: cache manager process
           └─10366 nginx: cache loader process

Nov 21 21:35:28 vps8009 systemd[1]: Starting nginx - high performance web server...
Nov 21 21:35:28 vps8009 systemd[1]: Started nginx - high performance web server.
UPD: Теперь спустя 15 мин. Запросы по http отбиваются со статусом 403 forbidden.
 
Последнее редактирование:
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
1,756
#11
Сайт работает на http, если ошибки, значит это кэш перенаправляет на https.
На сервере нечему перенаправлять.

site.png
 
Енот
Новичек
Регистрация
17 Янв 2018
Сообщения
100
#12
Сайт работает на http, если ошибки, значит это кэш перенаправляет на https.
На сервере нечему перенаправлять.
Т.е. у Вас сейчас он открывается по http в обычной, не мобильной версии?
UPD. Увидел, спасибо. С моего провайдера 403. Благодарю за помощь, без Вас бы долго я тупил. Тему можно закрывать.