Как перейти на протокол https на DDoS-Guard?

Енот
Новичек
Регистрация
26 Авг 2018
Сообщения
162
#1
Согласно данным оф. сайта CP Как добавить сайт в DDoS-Guard?для начала нужно:

1) В DNS домена создать CAA записи, в Терминале указываем 10) Получение SSL-сертификата и получаем собственно сам сертификат, ОК - ЭТО СДЕЛАНО.

2) DDos-GUARD.net прописываем все необходимые нам записи в DNS и получается что-то типо этого:



ОК - ЭТО СДЕЛАНО.

3) По инструкции CP Где прописать NS-записи от DDoS-Guard? Прописываем NS имена, ОК - ЭТО СДЕЛАНО.
Но после добавления NS записей те действия что делали в п.1 не имеют смысла т.к. домен делегируется и прежние DNS перестают работать, при этом на DDaoS-GUARD почему-то нет возможности добавлять CAA записи, как быть?

Screenshot_1.png
 

Вложения

Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,959
#2
CAA записи на самом деле не так важны и без них SSL работает.
Но после добавления NS записей те действия что делали в п.1 не имеют смысла т.к. домен делегируется и прежние DNS перестают работать
DNS домена - это либо CloudFlare, либо DDoS-Guard, либо в панели регистратора домена. Перечесления в соотношении ИЛИ, т.е. прописывать в каком-то одном.

Важно, чтобы на сервере правильно сгенерировался SSL, всё остальное не особо важно.
Логи смотреть: /var/log/get_ssl.log
 
Енот
Новичек
Регистрация
26 Авг 2018
Сообщения
162
#3
CAA записи на самом деле не так важны и без них SSL работает.

DNS домена - это либо CloudFlare, либо DDoS-Guard, либо в панели регистратора домена. Перечесления в соотношении ИЛИ, т.е. прописывать в каком-то одном.

Важно, чтобы на сервере правильно сгенерировался SSL, всё остальное не особо важно.
Логи смотреть: /var/log/get_ssl.log
Не могли бы вы подсказать по этому логу что не так, я не знаю где тут искать ответ :(
Важно, чтобы на сервере правильно сгенерировался SSL, всё остальное не особо важно.
Логи смотреть: /var/log/get_ssl.log
Мои логи:
Bootstrapping dependencies for Debian-based OSes... (you can skip this with --no-bootstrap)
Hit:1 http://nginx.org/packages/debian stretch InRelease
Get:2 http://security.debian.org stable/updates InRelease [39.1 kB]
Hit:3 http://cdn-fastly.deb.debian.org/debian stable InRelease
Get:4 http://cdn-fastly.deb.debian.org/debian stable-updates InRelease [49.3 kB]
Hit:5 https://deb.nodesource.com/node_8.x stretch InRelease
Get:6 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease [1,306 B]
Err:6 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 03C3AD3A7F068E5D
Fetched 89.7 kB in 4s (21.1 kB/s)
Reading package lists...
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 03C3AD3A7F068E5D
W: Failed to fetch https://mega.nz/linux/MEGAsync/Debian_9.0/./InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 03C3AD3A7F068E5D
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
augeas-lenses is already the newest version (1.11.0-3).
libaugeas0 is already the newest version (1.11.0-3).
ca-certificates is already the newest version (20190110).
gcc is already the newest version (4:8.3.0-1).
libffi-dev is already the newest version (3.2.1-9).
libssl-dev is already the newest version (1.1.1c-1).
openssl is already the newest version (1.1.1c-1).
python is already the newest version (2.7.16-1).
python-dev is already the newest version (2.7.16-1).
python-virtualenv is already the newest version (15.1.0+ds-2).
virtualenv is already the newest version (15.1.0+ds-2).
The following packages were automatically installed and are no longer required:
libevent-2.0-5 php7.0-mysql tcpd
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 195 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up netfilter-persistent (1.0.11) ...
Job for netfilter-persistent.service failed because the control process exited with error code.
See "systemctl status netfilter-persistent.service" and "journalctl -xe" for details.
invoke-rc.d: initscript netfilter-persistent, action "restart" failed.
[0;1;31m●[0m netfilter-persistent.service - netfilter persistent configuration
Loaded: loaded (/lib/systemd/system/netfilter-persistent.service; enabled; vendor preset: enabled)
Active: [0;1;31mfailed[0m (Result: exit-code) since Sun 2019-08-18 03:43:31 MSK; 7ms ago
Process: 15997 ExecStart=/usr/sbin/netfilter-persistent start [0;1;31m(code=exited, status=1/FAILURE)[0m
Main PID: 15997 (code=exited, status=1/FAILURE)

Aug 18 03:43:31 elsa.ns.cloudflare.com netfilter-persistent[15997]: run-parts: executing /usr/share/netfilter-persistent/plugins.d/15-ip4tables start
Aug 18 03:43:31 elsa.ns.cloudflare.com netfilter-persistent[15997]: run-parts: executing /usr/share/netfilter-persistent/plugins.d/25-ip6tables start
Aug 18 03:43:31 elsa.ns.cloudflare.com netfilter-persistent[15997]: ip6tables-restore v1.6.0: host/network `127.0.0.1' not found
Aug 18 03:43:31 elsa.ns.cloudflare.com netfilter-persistent[15997]: Error occurred at line: 17
Aug 18 03:43:31 elsa.ns.cloudflare.com netfilter-persistent[15997]: Try `ip6tables-restore -h' or 'ip6tables-restore --help' for more information.
Aug 18 03:43:31 elsa.ns.cloudflare.com netfilter-persistent[15997]: run-parts: /usr/share/netfilter-persistent/plugins.d/25-ip6tables exited with return code 2
Aug 18 03:43:31 elsa.ns.cloudflare.com systemd[1]: [0;1;39mnetfilter-persistent.service: Main process exited, code=exited, status=1/FAILURE[0m
Aug 18 03:43:31 elsa.ns.cloudflare.com systemd[1]: [0;1;31mFailed to start netfilter persistent configuration.[0m
Aug 18 03:43:31 elsa.ns.cloudflare.com systemd[1]: [0;1;39mnetfilter-persistent.service: Unit entered failed state.[0m
Aug 18 03:43:31 elsa.ns.cloudflare.com systemd[1]: [0;1;39mnetfilter-persistent.service: Failed with result 'exit-code'.[0m
dpkg: error processing package netfilter-persistent (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of iptables-persistent:
iptables-persistent depends on netfilter-persistent (= 1.0.11); however:
Package netfilter-persistent is not configured yet.

dpkg: error processing package iptables-persistent (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
netfilter-persistent
iptables-persistent
E: Sub-process /usr/bin/dpkg returned an error code (1)
Generating DH parameters, 2048 bit long safe prime, generator 2
This is going to take a long time
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,959
#4
Не могли бы вы подсказать по этому логу что не так, я не знаю где тут искать ответ :(
Проблема с пакетами, установите попробуйте их:
apt-get install iptables-persistent netfilter-persistent
 
Енот
Новичек
Регистрация
26 Авг 2018
Сообщения
162
#5

Вложения