Не срабатывает заголовок X-Content-Type-Options в Nginx, почему?

Енот
Новичо́к, через «о́»
Регистрация
13 Июн 2020
Сообщения
131
#1
Почему-то не срабатывает заголовок X-Content-Type-Options
Добавляю в conf,
Код:
add_header X-Content-Type-Options nosniff;
, перезагружаю nginx , но изменений нет. В чем проблема?
 
Енот
Новичо́к, через «о́»
Регистрация
13 Июн 2020
Сообщения
131
#3
nosniff работает на протоколе HTTPS.
Вы можете поставить сайт на собственный SSL-сертификат (cinemapress https) и опция будет добавляться в header.

https://github.com/CinemaPress/Cine...8/config/default/nginx/ssl.d/default.conf#L16
а другие заголовки типо refferer-policy? При добавлении в conf и перезагрузке ,ничего не срабатывает. Уже переискался
 
Енот
Новичо́к, через «о́»
Регистрация
13 Июн 2020
Сообщения
131
#5
Может CloudFlare переписывает.

Добавлять в /config/production/nginx/ssl.d/default.conf
При добавлении к примеру add_header Referrer-Policy "same-origin"; add_header X-Frame-Options "SAMEORIGIN"; в /config/production/nginx/ssl.d/default.conf и отключении Клауда, и перезагрузки сервера ничего не происходит и заголовки не задействованы. Я вообще не пойму, что может быть не так /config/production/nginx/ssl.d/default.conf прописан же везде в /config/production/nginx/conf.d/default.conf также заголовок
add_header X-Content-Type-Options "nosniff"; add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
который был установлен после перехода на https (cinemapress https) также не задействован. Что можно с этим сделать и все так настроить заголовки? Может через терминал...