Почему Nginx не слушает 443 порт?

URL сайта
скрыто
Енот
Новичек
Регистрация
17 Июн 2019
Сообщения
87
#1
Проблема в том, что если добавить в nginx.conf
Код:
server{
listen 443 ssl;                                       
ssl_certificate /etc/ssl/your_domain.crt;      
ssl_certificate_key /etc/ssl/your_domain.key;  
server_name your.domain.com;
Либо

Код:
http {
...
server {
...
listen 443 ssl;
...
}
}
То сайт просто перестает открываться по любому протоколу. Айпишник также перестает переадресовывать на ростелеком. Если код убрать, то http открывает, https невозможно установить соединение с сайтом. Как побороть проблему, ведь без ssl никак
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,954
#2
В конфиге по умолчанию уже прописаны настройки SSL, остается только сгенерировать сертификат.
 
Енот
Новичек
Регистрация
17 Июн 2019
Сообщения
87
#3
@Alisa, Сертификат сгенерирован, но все равно при подключении через https "Не удаётся установить соединение с сайтом"
 
Енот
Новичек
Регистрация
17 Июн 2019
Сообщения
87
#4
@Alisa, Можно ли как-то переустановить сертификат, сгенерированный через установочное меню? (Что и где удалить, если можно)
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,954
#5
@Alisa, Можно ли как-то переустановить сертификат, сгенерированный через установочное меню? (Что и где удалить, если можно)
После каждого создания, если оно неудачное, удалять папки командой: rm -rf /etc/letsencrypt /etc/nginx/ssl
Стоит лимит, на 5 генераций в неделю.
 
Енот
Новичек
Регистрация
17 Июн 2019
Сообщения
87
#6
@Alisa, переустановил ssl, все равно ничего. Да оно и понятно было, что это не поможет, если ssl нет, обычно заходит на сайт, но с предупреждением, а тут просто "Не удаётся установить соединение с сайтом". Абсолютно ничего не делал с конфигами сам (А если и делал, то все возвращал к дефолтному), в чем дело понять не могу
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,954
#7
@Alisa, переустановил ssl, все равно ничего. Да оно и понятно было, что это не поможет, если ssl нет, обычно заходит на сайт, но с предупреждением, а тут просто "Не удаётся установить соединение с сайтом". Абсолютно ничего не делал с конфигами сам (А если и делал, то все возвращал к дефолтному), в чем дело понять не могу
Смотрите ошибки в логах генерации: /var/log/get_ssl.log
И смотрите ошибки в Nginx после генерации: service nginx status
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,954
#9
Вначале у Вас была ошибка с отсутствием m поддомена.
Потом ошибок не видно, сертификат
/etc/letsencrypt/live/скрыто/fullchain.pem
/etc/letsencrypt/live/скрыто/privkey.pem
 
Енот
Новичек
Регистрация
17 Июн 2019
Сообщения
87
#10
@Alisa, ну то есть проблема в этом? Поддомен m. существует на сайте.
сертификат
/etc/letsencrypt/live/скрыто/fullchain.pem
/etc/letsencrypt/live/скрыто/privkey.pem
Насчет этого не понял, по указанному пути файлы есть, внутри ключи сертификата
 
Енот
Новичек
Регистрация
17 Июн 2019
Сообщения
87
#11
@Alisa, может в этой ситуацией единственным решением будет переустановка панели? Я честно говоря вообще без понятия куда копать
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,954
#12
@Alisa, может в этой ситуацией единственным решением будет переустановка панели? Я честно говоря вообще без понятия куда копать
Если сертификаты есть, значит смотрите чтобы они были раскомментированы в конфигурации /etc/nginx/conf.d/сайт.conf
 
Думает, что помогает
Регистрация
15 Дек 2017
Сообщения
3,954
#14
Енот
Новичек
Регистрация
17 Июн 2019
Сообщения
87
#15
@Alisa, чудеса какие-то, до этого эти строчки также были раскомментированы, я их закомментировал, потому что на гитхабе в вашем коде они также закомментированы, что так, что так ssl не работал. Видимо был криво сгенерирован сертификат. Спасибо за помощь